Na navigaci | Klávesové zkratky

Translate to English… Ins Deutsche übersetzen…

Apel na hostéry: chceme PHP 5.3!

PHP

Drazí provozovatelé hostingů, už je to tady. Před bezmála půl rokem vyšlo PHP 5.3.0. Přirozený nástupce řady 5.2 bez zpětně nekompatibilních změn. Víme, že jste s nasazením čekali, než se objeví následující setinková verze. Dnes se tak stalo, PHP 5.3.1 je venku.

Trojková řada přináší velké množství vylepšení, na které my, krásní a bohatí programátoři, toužebně čekáme. Neotálejte proto více a novou verzi PHP nám dopřejte. Když budete chtít, stihnete ji nasadit ještě dnes v noci! Stejně v televizi nedávají nic zajímavého. Děkujeme!

(tipy na hostingy, které už novou verzi mají, můžete posílat do komentářů)

Komentáře

  1. Honza Marek #1

    No Onebit má php 5.3.

    Jo… a má tohle být něco jako petice?

    před 7 lety | reagoval [2] iguana007
  2. iguana007 #2

    avatar

    #1 Honzo Marku, Pokud ano, tak máte můj podpis :)

    před 7 lety
  3. David Grudl http://davidgrudl.com #3

    avatar

    Pokud ano, tak se taky připojuju.

    před 7 lety
  4. Dundee http://blog.milde.cz #4

    avatar

    Rozšíření PHP 5.3 dost záleží také na tvůrcích linuxových distribucí. Kompilovat PHP ze zdrojáků se nikomu moc nechce.

  5. spaze http://exploited.cz #5

    avatar

    #4 Dundee, Naopak bych řekl, že PHP kompiluje spousta adminů. Nebo aspoň těch, co tomu rozumí. Na to, co bude v distru se nedá moc čekat, co když přijde klient, že chce ext/foobar, která zrovna v mým distru není a když náhodou je, tak je stará (čti stabilní)? Ale stálo by to za průzkum, kdo to jak dělá, možná by k tomu stačilo phpinfo().

    před 7 lety | reagoval [10] LesTR [24] Vojtěch Semecký
  6. Miloslav Ponkrác http://www.ponkrac.net #6

    avatar

    Já osobně jsem proti nasazení PHP 5.3. Právě proto, že obsahuje spousty novinek, tak se potřebuje trochu usadit a odchytat chyby. Jsem rád, že hosteři jsou trochu konzervativní. Já osobně raději spolehlivý web, než novinky hned. Já jako programátor raději podepíšu, ať zatím zůstane 5.2. Navíc PHP není projekt, kde by se na slovo „stable“ dalo betonově spolehnout. IMHO PHP 5.3 je třeba ještě nechat ještě nedůvěřivě jako nezaručeně stabilní, tím spíše, že obsahuje víc, než kosmetické úpravy.

    před 7 lety
  7. bene #7

    No bohuzel s tou kompatibilitou to neni uplne pravda. Treba magento vyhazuje chyby (pouziva parametr v __toString). Ted si nejsem jisty na jake urovni tu chybu vyhazuje. Ereg, ktery je bohuzel hodne pouzivan vyhazuje E_DEPRECATED, apod. Sice na produkcnim serveru by se chyby zobrazovat nemeli, ale vime jak to chodi ze :).
    Dalsi slabinou je debian. Ten ma 5.3 zarazenou v experimental, tudiz si jeste asi dlouho pockame.
    Kazdopadne, jsem pro co nejrychlejsi nasazeni.

    před 7 lety
  8. v6ak http://v6ak.profitux.cz/ #8

    Davide, co takhle slíbit nějaké zveřejnění seznamu hostingů s PHP 5.3? Nemyslím jen v komentářích. Odkazovat by se na to dalo i z webu Nette apod. Pro hostingy by to mohla být pěkná motivace.

    před 7 lety
  9. Jod #9

    avatar

    Dávnejšie sme skúšali nasadiť na našom hostingu php5.3. Výsledkom bolo že 80% webov nefungovalo vôbec (biela obrazovka) a zvyšných 20% bolo v nette ok. 
    Doteraz je problém, že niektorí idú ešte na starej php4 (včera sme s tým mali akurát problém).

    před 7 lety
  10. LesTR #10

    avatar

    #5 spaze, Pokud mi vyhovuje verze php samotného, tak se kompiluje jen ext/foobar proti aktuálnímu api. Samozřejmě se sestaví balíček, který má příslušné závislosti, takže při upgradu pak vidím, že je třeba přebalit i balíček s ext/foobar. Rozhodně je lepší starat se jen o jeden balíček, než
    lestr-nb:~# aptitude search php |awk ‚{print $2}‘ |grep ‚^php5‘ |wc -l
    60
    Tedy než o 60 balícku (v debianu)
    Takže s tvrzením, že admin co tomu rozumí, kompiluje php, rozhodně nesouhlasím : )

    před 7 lety | reagoval [20] spaze
  11. Enlil #11

    OneBit na žádost uživatele nabízí PHP 5.3.0 už měsíc :-D

    před 7 lety
  12. fos4 #12

    Mně například s PHP5.3 při zavolání mysql_close() spadne apache :( je to velká škoda a otrava, člověk by chtěl už co nejdříve vyuzivat nove feature ale s timto to moc nejde :(

    před 7 lety
  13. Miloslav Ponkrác http://www.ponkrac.net #13

    avatar

    Myslím, když to tak čtu, že hosting, který by nasadil PHP 5.3 by si vysloužil problém. Pokud by mi hoster nasadil bez mého vědomí pod sebe PHP 5.3, byl by to pro okamžitý důvod přejít jinam a to přesto, že bych asi neměl sebemenší technický problém.

    Prostě celý svět není testovací pracoviště nových verzí sw. Sice chápu, že řada lidí by viděla své novinky, ale ony určité věci taky musí chodit. A hostingy se také musí uživit.

    Schválili byste bance, kdyby na sw, který udržuje vaše peníze experimentovala s neotestovanými verzemi jako to třeba teď doporučujete s PHP 5.3? Uznávám PHP je trochu méně kritická aplikace, ale na takovém e-shopu dokáže chybka nadělat slušnou škodu a značné ztráty.

    Je mi naprosto jasné, že hračičkové by nejraději už teď nasadili PHP 6 a podepsali petice hostingům. Ale hračičkové si mohou hrát a dostávat za to peníze, když to ostatním bude trochu fungovat.

    Jaký je poměr hračičků a lidí očekávající, že neubdou muset kutit snadno vidíte na rozšíření Linuxu na desktopech, kterýžto je systém, který je dosnes na kutění postavený. Je to 1% hračičků. A to je asi tak procento, které by přijalo PHP 5.3, zbylé by to prokleli. Nevěřte tomu, že PHP 5.3 je odladěné, není. Není třeba si mazat med kolem pusy, že PHP 5.3 obsahuje obrovskou kupu chyb. Je v ní moc inovací a bude trvat minimálně několik setinových verzí, než nasazení do ostrého provozu bude známkou nesoudnosti člověka, který se o to chce pokusit.

    Upřímně, můj názor je, že za takových cca 10 měsíců bude PHP 5.3 nasaditelné a lze ho považovat za dostatečně prověřené. Sledujte changelogy a opravy chyb, které budou v PHP 5.3.2, 5.3.3, a několika dalších a uvidíte co vše v něm bude.

    Jestli si chcete hrát s neodladěnou a neprověřenou verzí PHP, prosím. Na svém serveru, na svém písečku, na svém počítači. Ok. Ale podepisovat petici hosterům, jenom proto, že Vám nedají Vaší hračku všem – přičemž hračka je stále ve stádiu, kdy teprve musí dokázat, že je dostatečně stabilní, kompatibilní a lze jí věřit – k tomu se myslím řada lidí včetně mě nepřipojí.

    před 7 lety
  14. v6ak http://v6ak.profitux.cz #14

    Ony tu jsou i metody zprovoznění více verzí paralelně, ne? Nechcete tu někdo hodit link na nějaký dobrý článek pro majitele webhostingů. (Možná budou většinou tak zkušení, že to nebudou potřebovat, netroufám si soudit.)

    před 7 lety
  15. HejTi http://sedo.tvorime.net #15

    avatar

    Taky spíš vidím problém v tom, že PHP 5.3 není ve stabilních distribucích linuxu (co jsem slyšel, tak alespoň debian a ubuntu – ten už to měl mít teď někdy, ale nějak z toho sešlo).

    Ale třeba webhosteři mohou tlačit dál…

    před 7 lety
  16. anonym #16

    avatar

    Ubuntu tuším odložilo zařazení PHP5.3 do KK kvůli nepodpoře http://www.hardened-php.net/suhosin/

    Určitě jsou hosteři, kteří kompilují. Ale je spousta dalších, kteří kompilují neradi, protože držet se distribučního řešení znamená větší stabilitu při menší zátěži na admina: nemusí vše sledovat, od toho jsou balíčkovači v distribuci. Ti mu třeba v Debianu pouští jen bezpečnostní patche co by neměli měnit funkčnost a to je pro správu pohodlnější.

    před 7 lety | reagoval [17] lopata
  17. lopata #17

    avatar

    #16 anonyme, Suhosin je už nějakou dobu i pro php 5.3
    Jinak apelovat může DG jak chce, web hostingy se tím řídit samozřejmě nebudou. Budou se řídit tím, co bude pro ně z hlediska zisku a nákladů nejlepší. Když se jim vyplatí udělat pro zákazníky s 5.3 nový stroj tak ho udělají. Rozhodně bych neviděl v horizontu tak minimálně roku a půl možnou variantu nahrazení 5.2 za 5.3, tím by dohostovaly.

    před 7 lety | reagoval [18] wdolek
  18. wdolek #18

    avatar

    #17 lopato, takze jinymi slovy, hosting, ktery dnes da penize na stroj s PHP5.3 ziska nyni vice zakazniku a bude si v budoucnu chrochtat blahem.

    osobne 5.3 vitam – nejsem hracicka, jsem programator. nektere nove funkce jsou namouveru uzitecne, a kez by uz byla nejaka verze PHP 7, ktera by se jeste vic priblizila pouzitelnosti…

    před 7 lety
  19. Koubas #19

    avatar

    Já myslím, že už i čeští webhosteři vědí, co je to virtualizace, a nemusí do uvažování o nasazení/nenasazení nové verze php tahat problémy jako nákup nového železa. Nebo jsem tak naivní? :) Ještě že klasický hosting jsem nikdy nebyl nucen použít, není nad VPSka a vlastní stroje, kde mám vše pod palcem :)

    před 7 lety | reagoval [21] spaze
  20. spaze http://exploited.cz #20

    avatar

    #10 LesTře, Tohle je celkem fajn způsob, možná jsem měl spíš napsat ne, že pokud tomu rozumí, tak PHP kompiluje, ale že pokud tomu rozumí, tak se kompilace nebojí, což je ostatně vidět i na tom tvým příkladu, to není úplně základní použití balíčkovacího systému – člověk tomu musí rozumět.

    Chtěl jsem nesouhlasit s „Kompilovat PHP ze zdrojáků se nikomu moc nechce.“ a nějak se mi to nepovedlo, za to sorry, ale ostatně i ten tvůj způsob zahrnuje větší, než malé množství kompilace :P

    před 7 lety
  21. spaze http://exploited.cz #21

    avatar

    #19 Koubasi, Dávno před virtualizací tady byla možnost provozovat dva webový servery na jednom železe.

    před 7 lety | reagoval [23] Koubas
  22. Karel Dytrych http:/www.vas-hosting.cz #22

    avatar

    Je mi potěšením oznámit, že Váš-Hosting.cz PHP 5.3 již nabízí. Abychom předešli problémům, tak jsme novou verzi dali na nový server a kdokoli si migraci ze stabilního 5.2.x serveru může vyžádat…

    před 7 lety
  23. Koubas #23

    avatar

    #21 spaze, Samozrejme neni problem provozovat treba pomoci FastCGI (coz je navic v kombinaci se suexecem asi nejbezpecnejsi a nejvykonnejsi zpusob) vice verzi PHP i pod jedinym http serverem, spousteni vice master procesu za timto ucelem by bylo celekm neefektivni a hlavne osklive. S virtualizaci je vse ale mnohem elegantnejsi a vetsi stupen izolace v tomto pripade taky neni na skodu, nemluve o dalsich moznostech, ktere prinasi.

    před 7 lety
  24. Vojtěch Semecký http://www.varlog.cz #24

    avatar

    #5 spaze, Tak to já bych teda neřekl :-) Souhlasím s #4 Dundee. I když to administrátoři umí, do ostrého provozu to nenasadí. V historii to tak vždycky bylo a historie se opakuje.

    Takže ať umíte PHP zkompilovat nebo ne, masové rozšíření PHP 3.5 nastane, až bude ve stabilních linuxových distribucích. Jde samozřejmě především o Debian squeeze a ten bude až tak v polovině roku 2010.

    před 7 lety | reagoval [25] v6ak [26] Koubas
  25. v6ak http://v6ak.profitux.cz #25

    #24 Vojtěchu Semecký, PHP 3.5 se, doufám, už nikdy masově nerozšíří ;-)

    před 7 lety
  26. Koubas #26

    avatar

    #24 Vojtěchu Semecký, Zrovna pro Debian existuje hodne zabehly alternativni repozitar (nejen) pro PHP a to dotdeb.org, kde se varej ty nejcersvejsi stable verze, presne podle debianiho vzoru – stejne nazvy balicku, vsechny extenze jako v deb. a pod. Hodne hostingu je pouziva i pro 5.2 radu, takze prechod na 5.3 je otazka prepsani url repozitare v sources.

    před 7 lety
  27. ksfga #27

    avatar

    #4 Dundee, Dovolit si pouzit na sdileny webhosting PHP z distribuce chce dost velkou kuraz anebo slusnou neznalost..

    před 7 lety
  28. Radek Tetík http://www.onecode.cz #28

    avatar

    PHP 5.3.1 pro Windows stále nemá rozšíření pro Firebird/Interbase. Až to bude dodělané, tak na našem serveru začneme uvažovat o aktualizaci. Vzhledem k tempu vývoje to bude tak za rok :-(

    před 7 lety
  29. Lweek #29

    avatar

    No vida, venku je PHP 5.3.3 a stejně mnozí hostéři zůstávají u 5.2 . Předevčírem sem měl tu čest vidět hosting s 5.2.6, není třeba dodávat že sem byl v rozpacích.

    před 6 lety

Tento článek byl uzavřen. Už není možné k němu přidávat komentáře.