Na navigaci | Klávesové zkratky

Translate to English… Ins Deutsche übersetzen…

Nette 2.4: už je za rohem!

Za pár týdnů vyjde nová verze Nette 2.4, nejnabušenější Nette všech dob. Postupně budu přidávat články, kde se dozvíte o všech novinkách, ale ještě předtím…

…by bylo skvělé, kdybyste otestovali, jestli pod ním běží vaše aplikace. Na všech svých webech už mám testovací 2.4 nasazenou a pochopitelně jsem přitom odhalil řadu chybiček, které bylo potřeba opravit. Tak prosím ověřte, jak jsou na tom vaše weby, než vyjde stable.

Verze 2.4 by měla být na 99 % kompatibilní s verzí 2.3. Zároveň upozorňuje, pokud používáte konstrukce, se kterými se už nepočítá do Nette 3.0. Může se stát, že něco z toho je pro vás důležité a chtěli byste funkčnost zachovat. Stačí o tom dát vědět. Ale samozřejmě co nejdříve.

Podrobné vysvětlení všech případů, kdy Nette generuje upozornění, a několika nekompatibilit mezi 2.3 a 2.4 najdete v tomto vláknu na fóru. A velmi stručný přehled novinek můžete zkouknout ve videu z poslední Poslední soboty.

Komentáře

  1. Finwe https://finwe.info #1

    avatar

    Nezapomeňte si před voláním composer update nastavit v composer.json i minimum-stability – kvůli DI je potřeba hodnota beta.

    před 7 měsíci | odpovědět
  2. Václav Kraus #2

    avatar

    Ja už všude mám novou Tracy. Na její novou ajaxovou kamarádku se zvyká hodně rychle ?

    před 7 měsíci | odpovědět

Zanechat komentář

Text komentáře
Kontakt

(kvůli gravataru)



*kurzíva* **tučné** "odkaz":http://example.com /--php phpkod(); \--