Na navigaci | Klávesové zkratky

Translate to English… Ins Deutsche übersetzen…

Statistika zastoupení PHP 5.x

Babylon, zmatení jazyků, resp. jejich verzí

Zajímalo by vás, jak jsou rozšířeny pětkové verze PHP? Váháte, zda ve svém open-source projektu stále udržovat kompatibilitu s PHP 4, nebo ji konečně pustit k vodě? Tak to vás asi překvapím.

Statistiky zastoupení PHP 5.x jsem hledal už dávno, leč marně. Až dnes mi ta zajímavá čísla prozradil francouzský server Nexen.net (viz statistiky za listopad). Měření provádí pravidelně každý měsíc na vzorku téměř 8 milionů webů.

Výsledky za listopad 2005

  • PHP najdete na 37% serverů (tedy je tu obrovský trh, který lze komerčně využít)
  • 1. místo: PHP 4.3.10 (30 %)
  • 2. místo: PHP 4.3.11 (24 %)
  • PHP 5.x jen 4.9 %
  • což je dokonce méně, než zastoupení PHP 4.1.x nebo 4.2.x

Nenadávejte však na hostéry. Ona čísla neříkají, kolik procent hostingů PHP5 nabízí, ale kolik zákazníků jej používá. V reakci na dřívější článek Dávám PHP4 rok, maximálně dva mi napsal Stanislav Petr z HOSTING90:

Představte si firmu xy, vyrábějící třeba kolíčky na prádlo… Oni mají www stránky, které běží nad nějakým redakčním systémem, který jim někdo někdy napsal. A teď jim zkuste říct, že budou muset znovu investovat několik desítek tisíc korun do přepisu, jenom proto, že php5 je teďka in… Takže tady platí jedno krásné pravidlo – na něco, co funguje, se nesahá.

Naprosto s ním souhlasím. Elegantní východisko je tedy provozovat obě verze a dát klientům možnost výběru. Kdo bude mít ale chuť vytvářet prostor pro verzi třetí, PHP 6?

Co z toho plyne? Například to, že Texy! bude dále podporovat obě verze PHP. V praxi to řeším tak, že kód píši v pětce s využitím většiny jejich vlastností a čtverkovou variantu (de)generuji pomocí převodníku. Prostě zabíjí dvě mouchy jednou ranou :-)

Jo, abych nezapomněl, pěkný nový rok!

Komentáře

  1. Marty http://martysbloq.wz.cz #1

    No kdyby se takový průzkum udělal v čechách, asi by to dopadlo stejně neslavně. Webmasteři se bojí nekompability a proto kódují pořád pro PHP4 (vlastní zkušenost). A navíc nabídka hostingů s PHP5 taky není největší.

    před 11 lety | reagoval [4] Martin Kuželka
  2. Jan Brašna http://www.janbrasna.com #2

    Já tedy co jsem měl tu čest, tak na každém hostingu či spravovaném serveru u společností, které používáme, je na výběr.

    před 11 lety
  3. pifik http://www.php-weblog.com #3

    takhle to resit kazdy, tak ustrneme kdesi v jeskyni.

    před 11 lety | reagoval [14] mk
  4. Martin Kuželka http://www.snehove-zpravodajstvi.cz #4

    #1 Marty, Marty, těch hostingů s podporou PHP5 je, řekl bych, už docela dost…

    před 11 lety
  5. ne0 #5

    A jaký kvalitní a levný nabízí PHP5, prosím? ;)

    před 11 lety | reagoval [7] johno [8] Martin Kuželka
  6. Radek Karban http://www.webdesign-reklama.cz #6

    Php 5 je tedy pro me nutnost, je sice takova striknejsi nez ctyrka, ale zase ma nove fce. Je to to same, jako kdybyste rekli ze delate ucetnictvi na papire a pres PC, casem vam to dojde ze jina cesta nez PC neni:)

    před 11 lety
  7. johno http://johno.jsmf.net/ #7

    avatar
    před 11 lety
  8. Martin Kuželka http://www.snehove-zpravodajstvi.cz #8

    #5 ne0, nerad bych to tu zapleveloval odkazy na hostingy. Proto si dovolím odkázat na téma " Jaký hosting s php5?":http://diskuse.jakpsatweb.cz/index.php?… z diskuze na Jak Psát Web.

    před 11 lety
  9. Petr Stříbný http://stribny.name #9

    Doteď mi bohatě na těch pár malých skriptíků stačilo PHP 4, ale všechny nové kódy píšu v OOP v PHP 5. Nicméně doufám, že pro šestku nebudu muset nic přepisovat.

    Ale řeknu to jinak, kdyby Apache podporoval Asp.net anebo by měl IIS neco jako mod_rewrite asi bych programoval v něm. Poslední dobou mi přijde, že dělají z PHP něco jako je .net. Prostě z PHP plnohodnotný plně objektový jazyk neudělají. To by z něj museli udělat typový jazyk.

    před 11 lety | reagoval [10] Jan Brašna
  10. Jan Brašna http://www.alphanumeric.cz #10

    #9 Petře Stříbný,

    Každopádně v .NET a PHP je podstatný rozdíl, zatímco jedno je framework s širokým záběrem použití, druhý je skriptovací jazyk. Tudíž srovnání hrušek a leča. Ono i PHP jako jazyk může být použito pro vývoj .NET aplikace.

    před 11 lety
  11. Petr Stříbný http://stribny.name #11

    Ano, o monu samozdřejmě vím (mám ho zkompilované na linuxu), ale myslím si, že není ještě úplně dodělané – až bude, bude to fajn.

    Za ten druhý odkaz dík – to jsem neznal.

    Já samozdřejmě právě z tohoto důvodu nechci PHP s .net srovnávat, jenže když PHP se vyvíjí cestou která mi asp.net připomíná. Jsem v podstatě začátečník, tekže věřím že časem se do všeho dostanu..

    před 11 lety
  12. MultiTricker #12

    avatar

    Já bych si to dovolil přirovnat k jiné rotaci ze světa počítačů a tou je hardware… Novou grafickou kartu si také nekoupíte pro staré hry, ale pro nové hry, které ji vyžadují a vy je chcete. Do té doby tento problém neřešíte.

    Stejně tak pokud budete mít aplikaci psanou v PHP5 kterou budete nutně chtít, tak se podřídíte a pořídíte si hosting s PHP5.

    Stačilo by, aby několik velice populárních webových řešení (fóra, redakční systémy) šířených pod licencí GNU/GPL vyžadovalo pouze PHP5 a drtivá většina provozovatelů těchto aplikací by přešla a to by hodně zamíchalo podílem jednotlivých verzí.

    Ale kde není vůle, tam není snaha a nic se neděje.

    před 11 lety
  13. lukas #13

    Osobně píšu kód pořád pro PHP 4, nemám nějak důvod investovat desítky hodin do čištění svého CMS kvůli těm několika klientům… Momentální stav je, že mi to teď nešlape ani pod nejnovější verzí PHP 4, protože ta vykopává error při pokusu o referenci na znak uvnitř řetězce… Docela mě děsí, že by nějaký aktivní zaměstnanec chtěl upgradovat PHP 4.x. Na to by měla být nějaká jasná pravidla, jako že nová verze PHP se bude instalovat jen jednou za rok (novou verzí myslím změnu v setině verze).

    před 11 lety
  14. mk #14

    #3 pifiku, Ono by stacilo, aby o vyvoji a navrhu jazyka trochu vic premysleli a nemuseli pak delat ruzne kotrmelce s porusovanim zpetne kompatibility apod.

    před 11 lety
  15. llook http://llook.wz.cz/weblog/ #15

    avatar

    Donedávna jsem ještě vyčkával. Z pár zbytečných ampérsandů se nepos*ru. Ale to s těma referencema na neproměnné (nefunkční function &foo() { return new Bar; }) a předávání referencí funkcím (psát fn($foo = new Bar) namísto fn(new Bar)) mi pomalu psaní kódu znechucuje.

    A protože motivace je jedna z nejdůležitějších hybných složek vývoje, přemýšlím jestli mám s PHP4 nadobro skoncovat, nebo psát tak, že na čtyřce se bude zbytečně alokovat paměť neustálým kopírováním objektů. Pětka asi vyhraje…

    před 11 lety
  16. Mirda #16

    Tenhle problém jsme taky řešili a dopadlo to neslavně. Místo přechodu na PHP5 jsme povětšinou s PHP skoncovali a přešli úplně jinam. Někdo ruby, někdo python, někdo java, když už přechod tak do toho pořádně prásknout! Kdo už by se s tím slepencem PHP patlal, no ne?

    před 11 lety

Tento článek byl uzavřen. Už není možné k němu přidávat komentáře.